【图】32位ubuntu14下安装qt5.5.1,出现No valid kits found【已解决】


        32位ubuntu14下安装qt5.5.1的完整流程,但是在安装完成后,出现了No valid kits found,这个问题,经过网上搜索,找到了答案,下面贴图告诉大家解决的办法,希望对大家有所帮助。


两个问题:

1:No valid kits found

2:cannot find -lGL


下载qt5.5.1和qt Creator 3.5.1,网上自行下载。安装完qt和qt creator 新建一个项目会出现如下问题:

No valid kits found,这是需要设置QT SDK。


解决方法:

1:点击蓝色的options或者打开 Tools->Options->Build&Runkits

2:根据下面三张图的顺序进行设置。

11.png

22.png

33.png

3:点击确定即可。


编译项目会出现下面这个错误:

cannot find -lGL


解决方法:

apt-get install update

sudo apt-get install libqt4-dev


上一篇 下一篇